Results 1 to 2 of 2

Thread: Networking/Proxy question

  1. #1
    Registered User
    Join Date
    Dec 2012

    Networking/Proxy question

    I'm not very experienced with networking and I'm attempting to set up a proxy. I've tried all sorts of things at this point without success, so hopefully someone here knows:

    I have a setup with four machines:
    LM: Local User Machine (Windows)
    S1: Server that is accessible from the local machine and all other servers (HP-UX)
    S2: Server that is accessible from S1 and S3 (RHEL5)
    S3: Server that is accessible from S1 and S2 (RHEL5)

    I'm trying to set up a process that runs indefinitely on S1 and basically acts like a router so I can connect to S2/S3 from LM by configuring applications to use S1 as a proxy. I know that I can use PuTTY on the local machine to create a connection to S1 and use that as a proxy, but I don't want to have to start that process on the local machine every time I turn it on. I'd prefer to just be able to point various applications (Filezilla, Java profiler, etc) directly at the proxy on S1 and get to their final destinations from there.

    I've tried using ssh -D <port> on S1 as well as direct port forwarding (-L), but it never seems to work. The SSH command itself is fine, but nothing happens when I attempt to use the proxy. The best result I've had is "connection refused", but I couldn't even figure out what was going on with that since OpenSSH doesn't seem to print any information about the way it's being utilized after starting up even with the -vvv flag.

    Am I missing something simple/obvious? Is this possible, or do I have to run something on my local machine?

  2. #2
    Registered User
    Join Date
    Dec 2012
    So just to make sure I wasn't crazy, I tried doing it on a different set of servers to see if it would work there. Turns out I was doing it right, but there's something else that's preventing me from connecting.

    I run the following on S1: ssh -D *:<port> localhost
    ...and then configure that hostort as my SOCKS proxy in various applications on the Windows box.

    However, this does not work in the servers that I originally mentioned. The port appears to be open when I check netstat (and openSSH indicates it's listening), but my local PC can't connect (it times out). At this point I'm assuming that the VPN has some sort of limitation on which ports you can connect to from external sources. The actual setup is:

    Windows box  ----- VPN ----- S1  ---- S2
                                  \      /
                                   \    /
    Unfortunately I'm not really sure how to test if that's the problem or how to find out which ports are allowed... Any ideas would be greatly appreciated.

    *Update* Looks like all ports aside from 22 are filtered when going through the VPN and I obviously can't listen on that, so I guess the only option is a local SSH tunnel. Oh well...
    Last edited by Desidero; 12-05-2013 at 05:14 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts